in SmartCard

GPShell install on Ubuntu trusty 14.04

Installed the GPShell on Ubuntu trusty version 14.04, there are quite a few dependencies required to be installed before GPShell can be installed,
1, install pcsc-lite, use below command, or download the source to make and make install.
sudo apt-get install pcsc-tools

error:
configure: error: install libudev-dev or use –disable-libudev
resolved by:
yum install libudev-dev* (for redhat…)

yum install pcsc* (for redhat)

I tried to download pcsc-lite-1.8.16.tar.bz2 and make install the package, but encountered below problem when install GlobalPlatform Library 6.0.0 later, so I didn’t use this method,

“winscard.h:90: error: expected declaration specifiers or ‘…’ before ‘LPSCARD_READERSTATE_A’”

2, install Openssl
after install Openssl, need further install libssl-dev,
sudo apt-get install libssl-dev

yum install openssl* (for redhat)

3, install zlib,GlobalPlatform Library 6.0.0 (include gppcscconnectionplugin-1.1.0.tar.gz,globalplatform-6.0.0.tar.gz)
yum install zlib* (for redhat)

4, pcscd needs to be running, use command sudo pcscd or sudo pcscd -d -f

5, be careful about the library dependency, sometime share library/object cannot be located, return no such file error. can use ldd command to check the dependency, use ldconfig to configure the dynamic linker, or copy the problem livery from /usr/local/lib to /usr/lib

test on the script under folder gpshell-1.4.4, list.txt,
changed mode_201 to mode 211 in the first line, result as below,
gpshell

Reference link:
https://www.openssl.org/source/
http://www.zlib.net/
https://github.com/LudovicRousseau/PCSC
http://www.alexander-petric.com/2011/08/javacard-compiling-and-installing-an-applet.html
https://github.com/sigma/globalplatform/tree/master/gpshell
https://launchpad.net/~k-o-/+archive/ubuntu/globalplatform
https://sourceforge.net/p/globalplatform/wiki/Installation/
https://sourceforge.net/projects/globalplatform/files/

Write a Comment

Comment

eighteen − eighteen =